use strict;
my $str = '{name="certbot.service", state="failed"}';
my $regex = qr/\{[^}]*\bname="(.*?)"[^}]*\}/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";