#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(?<=xmlUrl=")[^"]*"
Local $sString = "<outline type="rss" text="Tech Viral" title="Tech Viral" xmlUrl="http://feeds.feedburner.com/TechViral" htmlUrl="https://techviral.net"/>" & @CRLF & _
"<outline type="rss" text="The Verge" title="The Verge" xmlUrl="http://www.theverge.com/rss/full.xml" htmlUrl="https://www.theverge.com/"/>" & @CRLF & _
"<outline type="rss" text="Joystiq" title="Joystiq" xmlUrl="http://www.joystiq.com/rss.xml" htmlUrl="https://www.engadget.com/rss.xml"/>" & @CRLF & _
"<outline type="rss" text="BGR" title="BGR" xmlUrl="http://www.boygeniusreport.com/feed/" htmlUrl="http://bgr.com"/>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")