use strict;
my $str = '<outline type="rss" text="Tech Viral" title="Tech Viral" xmlUrl="http://feeds.feedburner.com/TechViral" htmlUrl="https://techviral.net"/>
<outline type="rss" text="The Verge" title="The Verge" xmlUrl="http://www.theverge.com/rss/full.xml" htmlUrl="https://www.theverge.com/"/>
<outline type="rss" text="Joystiq" title="Joystiq" xmlUrl="http://www.joystiq.com/rss.xml" htmlUrl="https://www.engadget.com/rss.xml"/>
<outline type="rss" text="BGR" title="BGR" xmlUrl="http://www.boygeniusreport.com/feed/" htmlUrl="http://bgr.com"/>';
my $regex = qr/(?<=xmlUrl=")[^"]*/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}