import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=xmlUrl=\")[^\"]*";
final String string = "<outline type=\"rss\" text=\"Tech Viral\" title=\"Tech Viral\" xmlUrl=\"http://feeds.feedburner.com/TechViral\" htmlUrl=\"https://techviral.net\"/>\n"
+ "<outline type=\"rss\" text=\"The Verge\" title=\"The Verge\" xmlUrl=\"http://www.theverge.com/rss/full.xml\" htmlUrl=\"https://www.theverge.com/\"/>\n"
+ "<outline type=\"rss\" text=\"Joystiq\" title=\"Joystiq\" xmlUrl=\"http://www.joystiq.com/rss.xml\" htmlUrl=\"https://www.engadget.com/rss.xml\"/>\n"
+ "<outline type=\"rss\" text=\"BGR\" title=\"BGR\" xmlUrl=\"http://www.boygeniusreport.com/feed/\" htmlUrl=\"http://bgr.com\"/>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}