# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=xmlUrl=\")[^\"]*"
test_str = ("<outline type=\"rss\" text=\"Tech Viral\" title=\"Tech Viral\" xmlUrl=\"http://feeds.feedburner.com/TechViral\" htmlUrl=\"https://techviral.net\"/>\n"
"<outline type=\"rss\" text=\"The Verge\" title=\"The Verge\" xmlUrl=\"http://www.theverge.com/rss/full.xml\" htmlUrl=\"https://www.theverge.com/\"/>\n"
"<outline type=\"rss\" text=\"Joystiq\" title=\"Joystiq\" xmlUrl=\"http://www.joystiq.com/rss.xml\" htmlUrl=\"https://www.engadget.com/rss.xml\"/>\n"
"<outline type=\"rss\" text=\"BGR\" title=\"BGR\" xmlUrl=\"http://www.boygeniusreport.com/feed/\" htmlUrl=\"http://bgr.com\"/>")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.