using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=xmlUrl="")[^""]*";
string input = @"<outline type=""rss"" text=""Tech Viral"" title=""Tech Viral"" xmlUrl=""http://feeds.feedburner.com/TechViral"" htmlUrl=""https://techviral.net""/>
<outline type=""rss"" text=""The Verge"" title=""The Verge"" xmlUrl=""http://www.theverge.com/rss/full.xml"" htmlUrl=""https://www.theverge.com/""/>
<outline type=""rss"" text=""Joystiq"" title=""Joystiq"" xmlUrl=""http://www.joystiq.com/rss.xml"" htmlUrl=""https://www.engadget.com/rss.xml""/>
<outline type=""rss"" text=""BGR"" title=""BGR"" xmlUrl=""http://www.boygeniusreport.com/feed/"" htmlUrl=""http://bgr.com""/>";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}