#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\A\s*(?>[^\s:]+:(?(1)\1|(\S+))\s*)+\z"
Local $sString = " 2:K1663" & @CRLF & _
" 3:K1663" & @CRLF & _
" 4:K1663" & @CRLF & _
" 5:K1663" & @CRLF & _
" 6:K1663" & @CRLF & _
" 7:K1663" & @CRLF & _
" 8:K1663" & @CRLF & _
" 13:K1663" & @CRLF & _
" 14:K1663" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")