using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\A\s*(?>[^\s:]+:(?(1)\1|(\S+))\s*)+\z";
string input = @" 2:K1663
3:K1663
4:K1663
5:K1663
6:K1663
7:K1663
8:K1663
13:K1663
14:K1663
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}