re = /\A\s*(?>[^\s:]+:(?(1)\1|(\S+))\s*)+\z/
str = ' 2:K1663
3:K1663
4:K1663
5:K1663
6:K1663
7:K1663
8:K1663
13:K1663
14:K1663
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end