import re
regex = re.compile(r"\A\s*(?>[^\s:]+:(?(1)\1|(\S+))\s*)+\z")
test_str = (" 2:K1663\n"
" 3:K1663\n"
" 4:K1663\n"
" 5:K1663\n"
" 6:K1663\n"
" 7:K1663\n"
" 8:K1663\n"
" 13:K1663\n"
" 14:K1663\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")