import Foundation
let pattern = #"\A\s*(?>[^\s:]+:(?(1)\1|(\S+))\s*)+\z"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
2:K1663
3:K1663
4:K1663
5:K1663
6:K1663
7:K1663
8:K1663
13:K1663
14:K1663
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)