const regex = /\A\s*(?>[^\s:]+:(?(1)\1|(\S+))\s*)+\z/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\A\\s*(?>[^\\s:]+:(?(1)\\1|(\\S+))\\s*)+\\z', 'g')
const str = ` 2:K1663
3:K1663
4:K1663
5:K1663
6:K1663
7:K1663
8:K1663
13:K1663
14:K1663
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}