using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"NWD[0-9]+ PADRAO -";
string input = @"NWD0 PADRAO -"", ""NWD1 PADRAO -"", ""NWD2 PADRAO -""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}