const regex = /NWD[0-9]+ PADRAO -/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('NWD[0-9]+ PADRAO -', 'g')
const str = `NWD0 PADRAO -", "NWD1 PADRAO -", "NWD2 PADRAO -"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}