# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/,\s?(\d{1})/, $1/gm;t' <<< "data = data.replaceAll(\", 6\", \",\n6\");
data = data.replaceAll(\",6\", \",\n6\");
data = data.replaceAll(\", 6\", \",\n6\");
data = data.replaceAll(\", 5\", \",\n5\");
data = data.replaceAll(\", 7\", \",\n7\");
data = data.replaceAll(\", 8\", \",\n8\");"