re = /,\s?(\d{1})/m
str = 'data = data.replaceAll(", 6", ",\\n6");
data = data.replaceAll(",6", ",\\n6");
data = data.replaceAll(", 6", ",\\n6");
data = data.replaceAll(", 5", ",\\n5");
data = data.replaceAll(", 7", ",\\n7");
data = data.replaceAll(", 8", ",\\n8");'
subst = ', $1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result