const regex = new RegExp(',\\s?(\\d{1})', 'gm')
const str = `data = data.replaceAll(", 6", ",\\n6");
data = data.replaceAll(",6", ",\\n6");
data = data.replaceAll(", 6", ",\\n6");
data = data.replaceAll(", 5", ",\\n5");
data = data.replaceAll(", 7", ",\\n7");
data = data.replaceAll(", 8", ",\\n8");`;
const subst = `, $1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);