use strict;
my $str = 'data = data.replaceAll(", 6", ",\\n6");
data = data.replaceAll(",6", ",\\n6");
data = data.replaceAll(", 6", ",\\n6");
data = data.replaceAll(", 5", ",\\n5");
data = data.replaceAll(", 7", ",\\n7");
data = data.replaceAll(", 8", ",\\n8");';
my $regex = qr/,\s?(\d{1})/mp;
my $subst = ', $1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";