import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ",\\s?(\\d{1})";
final String string = "data = data.replaceAll(\", 6\", \",\\n6\");\n"
+ "data = data.replaceAll(\",6\", \",\\n6\");\n"
+ "data = data.replaceAll(\", 6\", \",\\n6\");\n"
+ "data = data.replaceAll(\", 5\", \",\\n5\");\n"
+ "data = data.replaceAll(\", 7\", \",\\n7\");\n"
+ "data = data.replaceAll(\", 8\", \",\\n8\");";
final String subst = ", $1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}