#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(norm\.[0-9]+|conv\.[0-9]+)"
Local $sString = "module.features.denseblock4.denselayer16.norm.2.running_mean" & @CRLF & _
"module.features.denseblock4.denselayer16.norm.2.running_var" & @CRLF & _
"module.features.denseblock4.denselayer16.conv.2121.running_mean" & @CRLF & _
"module.features.denseblock4.denselayer16.conv.21341.running_var"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")