package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(norm\.[0-9]+|conv\.[0-9]+)`)
var str = `module.features.denseblock4.denselayer16.norm.2.running_mean
module.features.denseblock4.denselayer16.norm.2.running_var
module.features.denseblock4.denselayer16.conv.2121.running_mean
module.features.denseblock4.denselayer16.conv.21341.running_var`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}