import Foundation
let pattern = #"(norm\.[0-9]+|conv\.[0-9]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
module.features.denseblock4.denselayer16.norm.2.running_mean
module.features.denseblock4.denselayer16.norm.2.running_var
module.features.denseblock4.denselayer16.conv.2121.running_mean
module.features.denseblock4.denselayer16.conv.21341.running_var
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)