re = /(norm\.[0-9]+|conv\.[0-9]+)/m
str = 'module.features.denseblock4.denselayer16.norm.2.running_mean
module.features.denseblock4.denselayer16.norm.2.running_var
module.features.denseblock4.denselayer16.conv.2121.running_mean
module.features.denseblock4.denselayer16.conv.21341.running_var'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end