# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(norm\.[0-9]+|conv\.[0-9]+)"
test_str = ("module.features.denseblock4.denselayer16.norm.2.running_mean\n"
"module.features.denseblock4.denselayer16.norm.2.running_var\n"
"module.features.denseblock4.denselayer16.conv.2121.running_mean\n"
"module.features.denseblock4.denselayer16.conv.21341.running_var")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.