// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(norm\.[0-9]+|conv\.[0-9]+)").unwrap();
let string = "module.features.denseblock4.denselayer16.norm.2.running_mean
module.features.denseblock4.denselayer16.norm.2.running_var
module.features.denseblock4.denselayer16.conv.2121.running_mean
module.features.denseblock4.denselayer16.conv.21341.running_var";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}