#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.{0,2}(你知道)?#有?(什么|啥)(好?(吃的|食物)|((东西|玩意)?好吃))(吗|么|嘛|不)?$"
Local $sString = "#有什么好吃的" & @CRLF & _
"#有啥好吃的" & @CRLF & _
"#啥好吃" & @CRLF & _
"#什么玩意好吃" & @CRLF & _
"#啥东西好吃" & @CRLF & _
"去#吃啥" & @CRLF & _
"到#吃什么好吃的" & @CRLF & _
"去#应该吃啥"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")