use strict;
my $str = '#有什么好吃的
#有啥好吃的
#啥好吃
#什么玩意好吃
#啥东西好吃
去#吃啥
到#吃什么好吃的
去#应该吃啥';
my $regex = qr/^.{0,2}(你知道)?#有?(什么|啥)(好?(吃的|食物)|((东西|玩意)?好吃))(吗|么|嘛|不)?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}