using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.{0,2}(你知道)?#有?(什么|啥)(好?(吃的|食物)|((东西|玩意)?好吃))(吗|么|嘛|不)?$";
string input = @"#有什么好吃的
#有啥好吃的
#啥好吃
#什么玩意好吃
#啥东西好吃
去#吃啥
到#吃什么好吃的
去#应该吃啥";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}