package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.{0,2}(你知道)?#有?(什么|啥)(好?(吃的|食物)|((东西|玩意)?好吃))(吗|么|嘛|不)?$`)
var str = `#有什么好吃的
#有啥好吃的
#啥好吃
#什么玩意好吃
#啥东西好吃
去#吃啥
到#吃什么好吃的
去#应该吃啥`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}