# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/="([^"]*)%7B%7B(%20)?(.+?)(%20)?%7D%7D([^"]*?)"/="\1{{\2}}\3"/gmi;t' <<< "<a href=\"mailto:%7B%7B%20<Test>%20%7D%7D?subject=x\"
"