import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "=\"([^\"]*)%7B%7B(%20)?(.+?)(%20)?%7D%7D([^\"]*?)\"";
final String string = "<a href=\"mailto:%7B%7B%20<Test>%20%7D%7D?subject=x\"\n";
final String subst = "=\"\\1{{\\2}}\\3\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}