$re = '/="([^"]*)%7B%7B(%20)?(.+?)(%20)?%7D%7D([^"]*?)"/mi';
$str = '<a href="mailto:%7B%7B%20<Test>%20%7D%7D?subject=x"
';
$subst = "=\"\1{{\2}}\3\"";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;