# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r'="([^"]*)%7B%7B(%20)?(.+?)(%20)?%7D%7D([^"]*?)"'
test_str = ("<a href=\"mailto:%7B%7B%20<Test>%20%7D%7D?subject=x\"\n")
subst = "=\"\\1{{\\2}}\\3\""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE | re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur'' to prefix the regex and u"" to prefix the test string and substitution.