import Foundation
let pattern = #"="([^"]*)%7B%7B(%20)?(.+?)(%20)?%7D%7D([^"]*?)""#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
<a href="mailto:%7B%7B%20<Test>%20%7D%7D?subject=x"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"="\1{{\2}}\3""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)