#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[0-9]{1,2}([a-z]{2})?(\.|\/)?([0-9]{2})?(\.|\/)?(\s[A-Za-z]+\s)*[0-9]{2,4}"
Local $sString = "1st May 2020" & @CRLF & _
"2nd December 2020" & @CRLF & _
"3rd April 2020" & @CRLF & _
"10th May 2020" & @CRLF & _
"21st November 2020" & @CRLF & _
"1. Mai 2020" & @CRLF & _
"21.07.2020" & @CRLF & _
"07/21/2020" & @CRLF & _
"21/07/2020" & @CRLF & _
"Hugo hat am 21.07.2020 Geburtstag."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")