import Foundation
let pattern = #"[0-9]{1,2}([a-z]{2})?(\.|\/)?([0-9]{2})?(\.|\/)?(\s[A-Za-z]+\s)*[0-9]{2,4}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1st May 2020
2nd December 2020
3rd April 2020
10th May 2020
21st November 2020
1. Mai 2020
21.07.2020
07/21/2020
21/07/2020
Hugo hat am 21.07.2020 Geburtstag.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)