import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[0-9]{1,2}([a-z]{2})?(\\.|\\/)?([0-9]{2})?(\\.|\\/)?(\\s[A-Za-z]+\\s)*[0-9]{2,4}";
final String string = "1st May 2020\n"
+ "2nd December 2020\n"
+ "3rd April 2020\n"
+ "10th May 2020\n"
+ "21st November 2020\n"
+ "1. Mai 2020\n"
+ "21.07.2020\n"
+ "07/21/2020\n"
+ "21/07/2020\n"
+ "Hugo hat am 21.07.2020 Geburtstag.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}