re = /[0-9]{1,2}([a-z]{2})?(\.|\/)?([0-9]{2})?(\.|\/)?(\s[A-Za-z]+\s)*[0-9]{2,4}/m
str = '1st May 2020
2nd December 2020
3rd April 2020
10th May 2020
21st November 2020
1. Mai 2020
21.07.2020
07/21/2020
21/07/2020
Hugo hat am 21.07.2020 Geburtstag.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end