const regex = /[0-9]{1,2}([a-z]{2})?(\.|\/)?([0-9]{2})?(\.|\/)?(\s[A-Za-z]+\s)*[0-9]{2,4}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[0-9]{1,2}([a-z]{2})?(\\.|\\\/)?([0-9]{2})?(\\.|\\\/)?(\\s[A-Za-z]+\\s)*[0-9]{2,4}', 'gm')
const str = `1st May 2020
2nd December 2020
3rd April 2020
10th May 2020
21st November 2020
1. Mai 2020
21.07.2020
07/21/2020
21/07/2020
Hugo hat am 21.07.2020 Geburtstag.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}