# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[0-9]{1,2}([a-z]{2})?(\.|\/)?([0-9]{2})?(\.|\/)?(\s[A-Za-z]+\s)*[0-9]{2,4}"
test_str = ("1st May 2020\n"
"2nd December 2020\n"
"3rd April 2020\n"
"10th May 2020\n"
"21st November 2020\n"
"1. Mai 2020\n"
"21.07.2020\n"
"07/21/2020\n"
"21/07/2020\n"
"Hugo hat am 21.07.2020 Geburtstag.")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.