#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)[0-9]+ \| ([a-z]+):\/\/([x0-9]+\.[x0-9]+\.[x0-9]+\.[x0-9]+):([0-9]+)\/([0-9]+)"
Local $sString = " 189 | rtmp://x.x.x.x:1935/189" & @CRLF & _
" 190 | rtsp://x.x.x.x:554/190"
Local $sSubst = "$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)