import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[0-9]+ \\| ([a-z]+):\\/\\/([x0-9]+\\.[x0-9]+\\.[x0-9]+\\.[x0-9]+):([0-9]+)\\/([0-9]+)";
final String string = " 189 | rtmp://x.x.x.x:1935/189\n"
+ " 190 | rtsp://x.x.x.x:554/190";
final String subst = "$3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}