using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[0-9]+ \| ([a-z]+):\/\/([x0-9]+\.[x0-9]+\.[x0-9]+\.[x0-9]+):([0-9]+)\/([0-9]+)";
string substitution = @"$3";
string input = @" 189 | rtmp://x.x.x.x:1935/189
190 | rtsp://x.x.x.x:554/190";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}