$re = '/[0-9]+ \| ([a-z]+):\/\/([x0-9]+\.[x0-9]+\.[x0-9]+\.[x0-9]+):([0-9]+)\/([0-9]+)/m';
$str = ' 189 | rtmp://x.x.x.x:1935/189
190 | rtsp://x.x.x.x:554/190';
$subst = "$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;