import re
regex = re.compile(r"[0-9]+ \| ([a-z]+):\/\/([x0-9]+\.[x0-9]+\.[x0-9]+\.[x0-9]+):([0-9]+)\/([0-9]+)", flags=re.MULTILINE)
test_str = (" 189 | rtmp://x.x.x.x:1935/189\n"
" 190 | rtsp://x.x.x.x:554/190")
subst = "$3"
result = regex.sub(subst, test_str)
if result:
print(result)