const regex = /[0-9]+ \| ([a-z]+):\/\/([x0-9]+\.[x0-9]+\.[x0-9]+\.[x0-9]+):([0-9]+)\/([0-9]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[0-9]+ \\| ([a-z]+):\\\/\\\/([x0-9]+\\.[x0-9]+\\.[x0-9]+\\.[x0-9]+):([0-9]+)\\\/([0-9]+)', 'gm')
const str = ` 189 | rtmp://x.x.x.x:1935/189
190 | rtsp://x.x.x.x:554/190`;
const subst = `$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);