#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\d+(,\d+)*)$"
Local $sString = "# Inválido" & @CRLF & _
",12312.*" & @CRLF & _
"123,12312,,12312312" & @CRLF & _
"asdasd,123123,12312" & @CRLF & _
"1,3123,asadas,123123" & @CRLF & _
"12312,12312312,312312,1,3," & @CRLF & _
",abc,321" & @CRLF & _
"" & @CRLF & _
"# Válido" & @CRLF & _
"12312,12312312,312312,1,3" & @CRLF & _
"1,2,3" & @CRLF & _
"999,999"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")