use strict;
my $str = '# Inválido
,12312.*
123,12312,,12312312
asdasd,123123,12312
1,3123,asadas,123123
12312,12312312,312312,1,3,
,abc,321
# Válido
12312,12312312,312312,1,3
1,2,3
999,999';
my $regex = qr/^(\d+(,\d+)*)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}