# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(\d+(,\d+)*)$"
test_str = ("# Inválido\n"
",12312.*\n"
"123,12312,,12312312\n"
"asdasd,123123,12312\n"
"1,3123,asadas,123123\n"
"12312,12312312,312312,1,3,\n"
",abc,321\n\n"
"# Válido\n"
"12312,12312312,312312,1,3\n"
"1,2,3\n"
"999,999")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.