re = /^(\d+(,\d+)*)$/m
str = '# Inválido
,12312.*
123,12312,,12312312
asdasd,123123,12312
1,3123,asadas,123123
12312,12312312,312312,1,3,
,abc,321
# Válido
12312,12312312,312312,1,3
1,2,3
999,999'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end